Hi‑Res Web Graphics Workflow

Comparing Photoshop, Illustrator, Experience Design (XD), & Sketch
More people use Photoshop to design websites than Illustrator. The Adobe Preview CC mobile app only works
with Photoshop, not Illustrator. But Photoshop isn’t enough on its own, because we now need to save vector
art as SVG for the web. While Photoshop can finally import SVG files, it often cannot create them, requiring us
to use Illustrator, Experience Design (XD), or Sketch for SVG work.
Photoshop is widely used, but Sketch (from Bohemian Coding) is giving Photoshop a run for its money. This $99
app often has a faster workflow because it is specifically made for User Interface (UI) design.
Adobe Experience Design (XD) is a new app (currently in beta) made for UI and UX (User Experience) design. It’s
a direct competitor to Sketch (and looks/works very similarly to Sketch) that also has built-in prototyping tools.
Learn more in our hands-on classes:
• Photoshop for Web & UI: nobledesktop.com/classes/photoshop-web-ui
• Sketch in a Day: nobledesktop.com/classes/sketch-1day
• Adobe Experience Design (XD) in a Day: nobledesktop.com/classes/adobe-experience-design

Low-Res versus Hi-Res Graphics (1x versus 2x)
• Low-res graphics are referred to as 1x. Hi-res graphics are referred to as 2x (or Retina).
• PPI resolution does not matter, so just use 72ppi. The file’s pixel dimensions (width & height) are what matter:
− For a photo that fills the entire width of the screen of an iPhone SE you’d make the 1x file 320px wide.
The 2x file would be 640px wide (twice the width of the 1x file). Both 1x and 2x would appear at the same
physical size (the full screen width) but the 2x would appear sharper than the 1x.
− In HTML or CSS code you’d size both images to 320px. HTML/CSS pixels (sometimes called reference pixels)
do not always have a 1 to 1 correlation to the screen’s hardware pixels. On 2x iPhone screens the
640 image pixels will be scaled down to fit into the 320 reference pixels specified in HTML/CSS.
− HTML/CSS can determine if a user has a low-res or hi-res screen and download only the appropriate file.
− Read more about 1x and 2x at tinyurl.com/1x-versus-2x
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• Mac Users: When previewing graphics in the Finder using Quick Look (by pressing Spacebar) how large
will 1x versus 2x appear? As long as the files are named properly (filename.png and filename@2x.png),
here’s how it will work on macOS Yosemite or later.
− If you’re viewing the graphic on a 1x display, the 2x graphic will appear larger then the 1x graphic because
your 1x display cannot show the better quality at the same size.
− If you’re viewing the graphic on a 2x (Retina) display, the 1x and 2x graphics will both appear to be the
same size, but the 2x will show more details (be less pixelated), which is the way it’s supposed to work!

What Size & Resolution Should You Work At?
Adobe Photoshop
• There are pros and cons with working at 1x and 2x. Typically we recommend working at 2x because the files
look correct on 2x Retina displays, which can be scaled down to 1x as needed. The downside is text size,
sizes or elements, etc are all double what they will be in HTML/CSS. For example, the Photoshop type size of
24 px will be 12 px in CSS. Always work in even pixel amounts (so they are divisible by 2) and remember to
translate the 2x amounts into 1x when coding or giving specs to web developers. 2x files must be viewed at
50% zoom on 1x displays. For a deep comparison read tinyurl.com/ps-work-at-1x-2x
• You can work at 1x, but you must be careful about quality issues when scaling up to 2x. Use smart objects as
much as possible. 1x files must be viewed at 200% zoom on 2x displays (and therefore appear pixelated).
• If you will be previewing on a mobile device as you work, it’s better to design in a 2x file. Virtually all modern
mobile devices have 2x (Retina) displays. If working at 1x, the designs will appear pixelated when previewing
on mobile devices.

Adobe Illustrator, Adobe Experience Design (XD), & Sketch
• Illustrator, XD, and Sketch better mimic how web browsers work. In HTML/CSS an iPhone SE size (at 1x) is
320 x 568px (the 2x hardware is actually twice that). In these apps you design at the 1x size and export 1x
and 2x graphics. This way all dimensions, type sizes, etc. translate directly into HTML/CSS without you having
to do any math!
• Unlike with Photoshop, your design files can be viewed at 100% on both 1x and 2x displays.
• Illustrator, XD, and Sketch all use a vector display so the files will look sharp when viewed on both
1x and 2x displays. You would only see the pixelated display when a pixel preview is enabled
(Illustrator: View > Pixel Preview or Sketch: View > Canvas > Show Pixels).

What About 3x?
The iPhone 7 is a 2x (Retina) display, but the iPhone 7 Plus is a 3x (Retina HD) display. Android devices also
have 1x, 2x, 3x, etc. screens.
• For apps: You’ll need to create 3x graphics. For iOS apps you provide developers with 1x, 2x, and 3x PNG files.
For iOS apps it’s possible to use a 1x vector PDF and the 1x, 2x, and 3x versions will be created automatically,
but ask your developer for what they prefer. Android has an even greater variety of resolutions.
• For websites: 3x graphics are overkill because you really can’t see a difference between 2x and 3x.
If anyone’s eye sight is actually good enough to see a differences, it’s barely perceptible and not worth the
increase in file size. We do not recommend going beyond 2x for web graphics.
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Preview Designs in Real Time on Devices
Previewing designs on real devices helps you to judge the size of elements such as type and tappable elements.

Photoshop
• Adobe Preview CC is a free iOS app that works with Photoshop CC 2015 and later.
• Skala Preview for Mac works with Skala View on iOS. It works with Photoshop CS5 and later.

Illustrator
• Skala Preview for Mac works with Skala View on iOS. It works best with Photoshop, but it can be used to
send clipboard images to your iPhone or iPad. Copy something in Illustrator and it gets sent to your iPhone
or iPad. It can be a bit slow and if you don’t include a background the design will have black behind it. You
can also drag an .ai file onto Skala Preview’s window and it will send the first artboard.

Sketch
• Sketch Mirror is a free iOS app that lets you preview Sketch designs on your iPhone or iPad.
• Crystal lets you preview Sketch designs on Android. It’s not from the makers of Sketch, but reviews seem
positive. Learn more at https://crystal.smithy.productions

Adobe Experience Design (XD)
• The free Adobe Experience Design mobile app lets you preview your designs on iPhone, iPad, or Android.

Exporting 1x and 2x Graphics
Photoshop
• PNG, GIF, JPEG: For a multi-resolution export turn on File > Generate > Image Assets. Then name your
layers as follow. An assets folder containing the extracted files will be created alongside your PSD file.
− photo.jpg will produce a JPEG
− photo.jpg4 will produce a JPEG with 40% quality (the default value is 8)
− photo.jpg40% will produce a JPEG with 40% quality
− logo@2x.png, 50% logo.png will produce both 2x and 1x versions from the same layer (assume you’re
designing in a 2x Photoshop file).
− 250x250 logo.png will produce a PNG that is 250 x 250px
• Unlike Save for Web, the PNG-8 files created via Generate > Image Assets can be partially transparent and
a lot smaller than PNG-24!
• SVG: Photoshop can only extract Photoshop native vectors as SVG. If you bring in Illustrator art as a
Vector Smart Object, sadly Photoshop cannot export that as SVG. That majorly limits the usefulness of
Photoshop’s SVG export. Be careful, because Photoshop will appear to successfully export the SVG file, but it
actually contains a pixel-based graphic instead of vectors!

Illustrator
• Asset Export (New in CC Illustrator 2017):
− The Asset Export panel (Window > Asset Export) lets you export specific parts of an Illustrator file.
You can export SVG files, or export PNG and JPEG in multiple sizes (1x and 2x).
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• SVG Exporting Tips:
− Make sure the Illustrator artboard is properly sized to match the art. Then choose File > Save As (CC 2014
and older) or File > Export (CC 2015 or later) and set Format to SVG.
− To quickly size an artboard to a graphic: Group everything first. Then using the Artboard tool,
double‑click on the art you and the artboard should crop to the art!
− The last Illustrator CC 2015 update added a new SVG option under File > Export (in addition to the one in
File > Save As). The Export version will produce smaller, more optimized files so it’s now preferred over
the Save As method.
− You can copy art in Illustrator, switch to your code editor, and paste to get the SVG code!

Sketch
• Use the Make Exportable feature at the bottom right of the Inspector panel (on the right of the window).
Click the + button to add a 2x versions.
• Sketch export is decent, but it does lack some export options. It’s nice that it has PDF for iOS, but it does not
support GIF or PNG-8 (only has PNG-24). Ideally you’d open the final graphics in Photoshop (or ImageAlpha)
and optimize them smaller. You only have to do this once, right before you send the files to the web
developer. Because Sketch makes designing and exporting faster, you typically still end up saving time. Now
that we’re using SVG, this is also not as big of an issue.

Your JPEGs are Too Big! Proper Compression Settings for 1x & 2x
2x graphics have 4 times as many pixels (twice the width and twice the height) so you have to be careful about
file size. Proper compression can make a huge difference:
• 1x JPEGs should be compressed normally. Go with the lowest quality that looks OK.
• 2x JPEGs should be compressed more than 1x. The pixels end up being a lot smaller, so the JPEG artifacts are
smaller and less noticeable. For example, you can often use 20-45% quality on 2x JPEGs. That would be way
too much compression for 1x JPEGs, but it looks fine on 2x JPEGs.

Tips to Further Reduce the File Size of Web Graphics
ImageAlpha
• Free Mac only app available for download at pngmini.com 
(Windows users can try tinypng.com which is similar, but not an app. You upload images to the website.)
• Converts PNG-24 to PNG-8 (to save file size).
• Even if a PNG doesn’t have transparency, ImageAlpha’s dithering algorithm can sometimes look better than
Photoshop. A 256 color PNG from Photoshop that has too much banding might look fine from ImageAlpha.

ImageOptim
• Free Mac only app available for download at imageoptim.com
(Windows users can try tinyjpg.com which is similar, but not an app. You upload images to the website.)
• Shrinks file size with no loss of quality. Works best on PNG, GIF, but helps a bit on JPEG. Great for animated GIFs!
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Things to Consider While Designing
• Designing on a 2x (Retina) display: Some elements that look good on a 2x display will look bad on a
1x display. A common problem is thin type. It will look great on a Retina display, but on a 1x display it
can become too thin, blurry, or pixelated, making it hard or impossible to read (especially at small sizes).
If you’re on a Mac with a Retina display, get the free app Display Menu by searching for it on the Mac App
Store. It lets you switch between 1x (aspect ratio has a gray background icon) and 2x (aspect ratio has a
white background).
• Designing for performance is part of good design: Create designs that—whenever possible—can use CSS
instead of graphics. CSS will load faster for users and be easier/faster to update later. If rounding the edges
of photos or icons, provide the developer with square graphics, and let CSS do the rounding. Not only can
this be globally changed later, it doesn’t require you to use transparency, which may increase the file size!
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