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CC 2017 (Illustrator 21) Released November 2015

Redesigned File > New Dialog
•	 File > New has been completely redesigned. It’s no longer a traditional dialog with menus, instead using tabs 

for different types of documents and thumbnails for the various presets. 

•	 A main new feature of this dialog is the ability to browse and download pre-made templates.

•	 We find this dialog to be very slow. Adobe is aware and hopefully it will be improved in a future release.

Updated Interface
•	 The interface and icons have been updated.

Zoom to Selection
•	 When using the Zoom tool or keystrokes, Illustrator now zooms towards the selected art.

New Type Objects are Filled with Placeholder Text
•	 When you create a new type object it will initially be filled with lorem ipsum. The placeholder text will be 

selected, so you can type the desired text without even having to hit delete. 

Live Font Preview
•	 Select one or more type objects and open the font list in the Control panel and Character panel. As you 

hover over the font names you’ll see the selected type objects preview the fonts in real time!

Finding the Right Font
•	 At the top left of the font list of the Control panel and Character panel, you can filter fonts by Serif, 

Sans Serif, Script, etc.

•	 At the top of the font list of the Control panel and Character panel you can find fonts that are visually 
similar to the selected font by clicking the Apply Similar Filter button .

Pop-Up Alternative Glyphs
•	 After selecting a character, you may see an underline below it. Mouse over the character to see 

alternate glyphs (which you can click on to choose).

Improved Pixel Snapping (Pixel-Perfect Art)
•	 A new Object > Make Pixel Perfect option will snap your selection to the pixel grid.

•	 At the top right of the Options bar (at the top of the screen) there is a new toggle button for Align art to 
pixel grid on creation and transformation . Click the arrow to its right for more advanced options.

Hidden Character Keystrokes
•	 There are now keystrokes for en space, em space, thin space, superscripts, subscripts, discretionary 

hyphen, and non-breaking space. You can find them in Type > Insert Special Character or Type > 
Insert WhiteSpace Character. 
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CC 2015.3 (Illustrator 20) Released June 2016

New Web Export
•	 Export for Screens dialog: (File > Export > Export for Screens) lets you export artboards or artwork with 

various options.

•	 Asset Export panel: (Window > Asset Export) lets you collect assets for easier export.

•	 Save for Web has been moved into File > Export. It has been marked as Legacy because the new export 
methods are where Adobe will focus their attention and new features from now on.

Live Shapes Enhancements
•	 Polygons retain their Live Shape properties after being modified (scaled, sheared, reshaped, etc.).

•	 Look in the Transform panel for Live Shape properties.

•	 If a polygon has been modified (such as stretching a triangle), a new Make Sides Equal button will appear in 
the Transform panel.

CC 2015.2 (Illustrator 19.2) Released November 2015

New Live Shapes
•	 Shapes (such as polygons) are now live, so you can interactively change how many sides they have, how 

round their corners are, etc. Most shape tools have been updated to make editing shapes easier!

New Shaper Tool
•	 Use gestures to create simple shapes such a circles, polygons, lines, etc.

•	 Scribble on top of overlapping areas to merge them into a single shape. (Start outside the shape to remove 
that section from the overall shape.)

•	 You can select and adjust shapes while using the Shaper tool, so you don’t have to change tools as often.

Dynamic Symbols
•	 You can now modify the appearance (stroke, fill, opacity, etc.) of individual symbol instances (use the 
Direct Selection tool ). This lets you have a master symbol that controls the overall appearance, but you 
make various instances look different. You can also scale, rotate, mirror, and skew instances of a symbol.

SVG Improvements
•	 New SVG Export: In addition to File > Save As, there’s a new way to create SVG via File > Export. You can 

also choose File > Export Selection.

•	 The new export writes cleaner SVG code for smaller files.

Miscellaneous
•	 Smart guides now indicate when you are drawing a perfect shape (such as a square or circle) without having 

to use a keystroke.

•	 The Creative Cloud Charts (Preview) has ended. It is no longer part of Illustrator.
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CC 2015 (Illustrator 19) Released June 2015

Miscellaneous
•	 10x greater zoom magnification: The max is now 64,000% (was 6,400%).

•	 10x faster zooming & scrolling: Illustrator now uses supports graphics cards (GPU) for faster performance 
(and animated zoom).

•	 GPU vs. CPU Preview: When switching between Outline and Preview modes, you can now use the CPU or 
GPU to create the preview. The GPU should be faster, but it may look different. If you have any display issues, 
switch to the CPU preview (in the View menu).

•	 Auto-File Recovery: If you crash, relaunch Illustrator and your work can be restored. By default it saves 
recovery data every 2 minutes, but you can change that in Preferences > File Handing & Clipboard.

Creative Cloud Charts (Preview)
•	 The charting feature in Illustrator has not seen any changes in a long time, but now there is a preview 

(beta version) of the new feature called CC Charts. It’s just a preview of what Adobe’s working on, so it’s not 
complete and may change in future versions.

•	 Using CC Charts is different than other Illustrator features you’re used to, because some work is done in 
Illustrator, and the rest in a web browser. Data is input in the web browser, and design is done in Illustrator.

•	 Creative Cloud File Sync must be enabled for CC Charts to work. If it’s not, you won’t be able to edit a chart 
(the progress icon will go around, but nothing will happen). That’s because the chart asset is added to your 
CC Library. Check the sync status at the bottom of the Libraries panel (mouse over or click the Creative 
Cloud button).

Adobe Stock
•	 Adobe is now selling stock photos and illustrations (they purchased Fotolia). Images can be purchased 

individually or via subscription plans. Choose File > Search Adobe Stock to go to stock.adobe.com

CC 2014.1 (Illustrator 18.1) Released October 2014

Color
•	 Adobe Color CC: Formerly called Kuler, Adobe Color is a cloud-connected service used to mix and share 

color themes. Found in Window > Color Themes.

Automatic Sizing Area-type
•	 Never see overset text again! Area-type frames have a new handle on the bottom (in the middle). Double-

click that handle and the text frame will automatically adjust its height based on the text inside. Add or 
remove text and the text frame will automatically adjust!

New Tools
•	 Join Tool: Drag over the intersection of lines and Illustrator will join and clean them up. If needed it will 

shorten or extend lines as needed to create a better join.
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•	 Curvature Tool: 

−	 This tool lets you draw curves without having to understand the way the Pen tool’s bezier curves work. 

−	 With a line selected, use the Curvature tool to drag the line and change the curve.

−	 Double–click a point to change it between a curved and straight corner.

Creative Cloud Libraries
•	 Creative Cloud Libraries let you store colors, brushes, text styles, graphics, and vector images in a single 

place that is available across multiple Adobe apps (such as Photoshop and Illustrator). You’ll find it in 
Window > Libraries.

•	 Want to share a library with coworkers? At the top right the Libaries panel, go into the panel menu and 
choose Collaborate.

CC 2014 (Illustrator 18) Released June 2014

Better Rounded Rectangles: “Live Shapes”
•	 Rounded rectangle corners now properly maintain their roundness! They no longer become distorted when 

resizing the rectangle. You can also numerically set the corner radius in the Transform panel.

•	 When drawing a rectangle (rounded or not) the Transform panel will open so you can set options such as 
size and the new corner radius options (size, corner type, etc.). 

You may not want the Transform panel to automatically open every time you create a rectangle. To disable 
this behavior, at the top right of the Transform panel, go into the panel menu  and uncheck Show on 
Rectangle Creation.

Pen Tool & Anchor Points
•	 Pen Tool Preview: A new preview lets you see the path before you make the next point. This works 

like the same option found in Photoshop. You can turn this on or off in the Preferences dialog’s 
Selection & Anchor Display section. At the bottom, you’ll see the option for Enable Rubber Band for 
Pen Tool.

•	 Unequal Anchor Points: While drawing a curve, hold Command (Mac) or Control (Windows) as you drag to 
keep the handles paired, but unequal in length.

•	 Re-Pair Anchor Points: Corner points have two handles that are not paired. Moving one side does not 
affect the other. In previous versions of Illustrator, when you changed a corner point back into a smooth 
point (so the handles are paired again), the shape of the original curve was changed. In CC 2014, when using 
the Anchor Point tool , hold Option (Mac) or Alt (Windows) and click on one of the handles to make the 
anchor point smooth again (the handles become paired). The handle you click on will move, but the other 
handle will remain unchanged. This helps maintain the original curve’s shape.

•	 Path Segment Reshape Update: Not everyone liked the new Path Segment Reshape behavior that was 
introduced in the January 2014 release. To revert to the earlier behavior, go into the Preferences dialog’s 
Selection & Anchor Display section and check on Constrain Path Dragging on Segment Reshape.



Illustrator CC: What’s New?

NOBLEDESKTOP.COM 212-226-4149� PAGE 5

Miscellaneous
•	 Welcome Screen: A new welcome screen appears when no files are open. To disable this screen, switch 

from the Create tab to one of the other tabs (New Features, Getting Started, or Tips & Techniques). 
Scroll to the bottom right and check on Don’t Show Welcome Screen Again. (It can later be found in 
Help > Welcome.)

•	 Changes to Snap to Pixel, Point, Grid: Anchor handles no longer snap to a grid or a point. Adobe says this 
offers finer control while editing paths. For example, you may want points and objects to snap to a pixel grid, 
but not the anchor handles. 

This new behavior applies to snap to document grid or snap to point, not just the pixel grid. While we agree 
that anchor handles snapping to the pixel grid was sometimes problematic, it’s sometimes nice to have the 
option of snapping anchor points to a grid. We have not found any preference or control over this, so it 
seems that anchor points can no longer snap to a grid. They do still snap to guides though.

Improved Typekit Integration
•	 When opening a file that is missing fonts, Illustrator will look on Typekit to see if it’s available and offer to 

activate (sync) it for you. 

CC 2014 (Illustrator 17.1) Released January 2014

Live Corners
•	 We’re excited to finally see this feature in Illustrator, and done with such flexibility! 

•	 Easily change the shape of corners. Change all the corners or specific ones. You can make them rounded, 
inverted round, or chamfer (as shown below). 

•	 Live corners work on any shape, not just rectangles. You can even change multiple objects at once!
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•	 The Rounded Rectangle tool  now uses live corners, so you can edit the corner radius any time.

•	 Here are a few ways to edit the live corners:

−	 Select your object(s) with the Selection tool , then switch to the Direct Selection tool (   ). You should 
see the Live Corners widgets (which look like dots) in the corners. Drag any widget to edit the size of the 
corner radius. This also works if you select specific points with the Direct Selection tool (   ).

−	 Double-click a Live Corners widget to numerically edit the settings (as shown above).

−	 Select your object(s) with the Selection tool , then switch to the Direct Selection tool . In the 
Control panel at the top of the screen edit the Corners amount. This also works if you select specific points 
with the Direct Selection tool .

−	Option–click (Mac) or Alt–click (Windows) on a Live Corners widget to cycle through the three corner 
styles. 

−	 While dragging a Live Corners widget, press the Up or Down Arrow keys to cycle through the corner styles.

•	 As you drag the Live Corners widget, the corner will become red when you have reached the maximum size.

•	 You can hide the Live Corners widget with View > Hide Corner Widget.

Improved Pencil Tool
•	 The Pencil tool  has been reworked and can now create simple, smooth curves that don’t have a lot of 

anchor points. It also works more intuitively, allowing you to continue and end paths easily without having to 
hold keystrokes.

•	 Double-click the Pencil tool  to see its options. Drag the Fidelity slider to the far right (Smooth) to get the 
simplest curves with the fewest anchor points. Draw with the Pencil tool  and when you release, the line 
will become smoother, simpler, and have fewer points than previous versions of Illustrator.

•	 The Pencil tool  can now continue a path more easily. Mouse over the end of the path. You’ll see the 
continue-path cursor  and can start drawing a new segment of the path.

•	 To draw straight lines constrained to 45° or 90° angles, hold Shift and then draw a segment. You’ll see the 
straight-segment cursor  while doing so.

•	 To draw straight lines that are not constrained, hold Option (Mac) or Alt (Windows) and then draw 
a segment. NOTE: This means the Smooth tool  is no longer available by holding Option (Mac) or 
Alt (Windows) while using the Pencil tool.

•	 To merge two paths, select them both. Using the Pencil tool , draw from the end of one path to the end of 
another. When you see the path-merge cursor  you can release the mouse.

Path Segment Reshaping
•	 The Convert Anchor Point tool is now simply called the Anchor Point tool  and has gained a new ability 

to easily shape curved and straight lines.

•	 To change a straight line into a curved line, use the Anchor Point tool  and drag the middle of a 
straight line segment. (Drag anywhere in the line segment except on an anchor point.)

•	 You can also use the Anchor Point tool  to edit a curved segment. (Hold Shift to keep the 
curve symmetrical.)
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Change The View of Perspective Drawings
•	 When the Perspective Grid was first introduced we were surprised to discover that changing the 

Perspective Grid had no effect on attached artwork. Luckily that has been fixed. Artwork can now be adjusted 
when you alter the horizon line and vanishing points. (This is available for two- or three-point Perspective 
Grids only.)

•	 To change the grid and have the artwork change with it:

−	 Add artwork to a Perspective Grid.

−	 Select the Perspective Grid tool  to make sure the grid is visible.

−	 Lock the Station Point on the Perspective Grid (View > Perspective Grid > Lock Station Point).

−	 Change a vanishing point or horizon line and the art will change along with it.

Typekit Integration
•	 In the font menu you can choose to show only the Typekit fonts. There’s also a button to Add Fonts from 
Typekit for easy access (it takes you to typekit.com). 

Miscellaneous
•	 When resizing Artboards, you can now resize from the center point by holding Option (Mac) or 
Alt (Windows). Hold Option–Shift (Mac) or Alt–Shift (Windows) to resize proportionally from the center.

•	 The Swatches panel has new icons to switch between Fill and Stroke.

•	 The Swatches panel has new buttons to easily switch between List and Thumbnail views.

•	 The Transparency panel now has a slider instead of a list of numerical values.

•	 The Layers panel now remembers which layers are open or closed, even after closing and reopening files.

•	 File > Place now has a default keystroke: Cmd–Shift–P (Mac) or Ctrl–Shift–P (Windows).

•	 When saving SVG files there is a new Responsive option (if you don’t see it click More Options). Check this to 
remove the absolute width/height so the artwork will scale proportionally.

•	 You can create custom Tool panels in Window > Tools > New Tools Panel. Drag your preferred tools from 
the main Tools panel into the custom panel.

Prior Updates

Sync settings using Creative Cloud
•	 You can now sync Preferences, Brushes, Swatches, Workspaces, etc. across all your computers using your 

Creative Cloud account.

•	 Choose Preferences > Sync Settings and choose what you want synced.
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Share Your Work on Behance
•	 You can upload your images to Behance directly from within Illustrator using File > Share on Behance.

Multiple File Place
Like InDesign, Illustrator can now place multiple files:

•	 Go to File > Place. 

•	 Choose multiple files by selecting one, then Shift–click another file to select a range of continuous files, or 
Command–click (Mac) or Control–click (Windows) a specific file to just add that one.

•	 After clicking Place to close the dialog, the cursor will be loaded with all the graphics. Use the arrow keys to 
switch between them and choose the one you want to place first.

•	 Click on the artboard to place the file at it’s original size, or drag to set a custom size.

Images in Brushes
•	 Art, Pattern, and Scatter brushes can now contain pixel-based graphics. The brushes will act like ones 

containing vector-based art, allowing you to reshape and edit them. 

•	 Using pixel-based art in brushes will allow you to create more natural and organic-looking design elements 
than you would be able to using only vector art.

Touch Type Tool
•	 As it’s name implies, the Touch Type tool does work with multi-touch devices, but they are not required to 

use this new tool. Choose a single letter in some text and you can move, scale, or rotate it without having to 
break it out of the main text area.

On-Art Free Transform Tool
•	 To get the most out of the Free Transform tool, you used to have to know keystrokes. When you select the 

tool, you’ll now see a new toolbar with four icons in the document’s window. Click on the various icons to 
change the way the Free Transform tool works.

•	 Touch-screens are now supported with this tool.

OS Gestures Support
•	 If your device and OS support gestures such as pinch to zoom, Illustrator now supports them.



Illustrator CC: What’s New?

NOBLEDESKTOP.COM 212-226-4149� PAGE 9

Pattern Brush: Automatic Corner Generation
To create a good Pattern Brush you used to have to create swatches for the line portions as well as corners. 
Now Illustrator can generate the corners automatically for you, so you only need one swatch for the line 
portions. Of course you can still provide custom drawn corners if you prefer, but having the option to let 
Illustrator create these for us can be a huge help and time saver.

Generate CSS code
•	 A new CSS Properties panel (Window > CSS Properties) lets you copy CSS code for selected elements.

•	 Unless you change the default settings, you must name elements in the Layers panel. The name you give 
each element will be used in the CSS. If you name an element with a standard HTML tag (such as h1, p, nav, 
etc) it will create a CSS tag rule, otherwise it will create a class. 

Copy & Paste SVG (Scalable Vector Graphics)
•	 Instead of having to export an SVG file (which you can still do), now you can copy art in Illustrator, switch 

to a code editor and paste SVG code! Browser support for SVG is getting better, so this is exciting for 
web developers!

Searching Swatches & Colors
•	 The Swatches panel search (Swatches panel menu > Show Find Field) 

has been improved. Instead of highlighting the swatch it thinks you’re 
trying to find, it starts hiding swatches that don’t match the search, only 
showing correct matches. It provides more flexible search options (such 
as finding by color value like m=25 instead of name only) as well as a 
better way to see the swatch you wanted to find.
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•	 In the Color Picker (double-click a Fill swatch), there’s now a search field at the bottom. 

Package & Updates Links Panel
These were technically added in an earlier Creative Cloud release, but you may not be aware of them.

•	 Package (like in InDesign): To collect all links, files and fonts used in an Illustrator file, choose File > Package 
and follow the prompts.

•	 The Links panel (Window > Links) can now unembed graphics. Select a file in the Links panel and in the 
panel menu  choose Unembed.

Guides
•	 You can now double-click on the ruler to create a guide at that specific location. 

•	 Hold Shift as you double-click on the ruler and the new guide will be snapped to the nearest mark on 
the ruler.

•	 You can create a pair of intersecting horizontal and vertical guides by holding Command (Mac) or 
Control (Windows) and dragging from the intersection of the rulers to where you want the guides in 
the document.

Miscellaneous
•	 Converting between Area Type and Point Type (and vice versa) is now easier. Just double-click the circle to 

the right of the text. 

DOUBLE-CLICK THIS CIRCLE

•	 The font menu has been revamped. There are now two search modes (shown below). Search First Word 
only acts like previous versions of Illustrator. Search Entire Font Name is new (and the default) and when 
you search for a font, it live filters down the list of fonts to make it easier to find the font you’re looking for. 

•	 In the Separations Preview panel there’s a new checkbox for Show used spot colors only.


